Nissan Pathfinder Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey All,
Looking for a little help on a stalling issue. My 2005 Pathfinder was stolen (the thieves know quality) and it was recovered. I had the locks cylinders changed as they stole a key. Over the next hundred or so miles the car has shut off, stalled twice. Both times there was no hesitation, rough running, just one second running and the next not. I believe in both instances the lights, radio etc stayed on. Just put it in park and fired right back up. At first I thought it might be the crank or cam position sensors, I did replace the crank sensor about 5k ago (150k total miles). Seems like a bit of a coincidence that this would start right after the locksmith was messing with the ignition. No CEL and no codes come up on a reader. What do you all think? Failing ignition switch? Sensors failing?
Thanks for any insight and suggestions.
 

·
Administrator
2015 Pathfinder SL - Tech 4WD
Joined
·
3,370 Posts
Welcome to the forum.

Your vehicle should have an immobilizer system. Wondering if the locksmith programmed the new keys properly to the vehicle.
Any lights on the dash?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
No lights on the dash and no codes. No drivability issues. I tried wiggling the key while the car was running to see if I could get it to stall but no luck. When my crank position sensor started to fail, the car died twice before the check engine light finally went on so I'm not convinced it's not the cam position sensors.
I'd think if the key wasn't programmed, the car wouldn't start and drive normally. Maybe having the locksmith messing with the ignition cylinder caused it to start malfunctioning.
Thanks for the warm welcome!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
update.
Took apart the dash and directly wiggled wires. No stall. Guess I'll replace the cam sensors and maybe the ignition switch.
Any other suggestions?
Thanks.
 
1 - 5 of 5 Posts
Top