Nissan Pathfinder Forum banner

1 - 9 of 9 Posts

·
Super Moderator
2015 Pathfinder SL - Tech 4WD
Joined
·
2,576 Posts
Discussion Starter #1
I took my PF to the to the dealer last week to address a long list of issues one of which was the steering wheel volume control.
The dealer replaced the steering wheel controls (which I appreciate) but guess what.... they installed the wrong PN &%[email protected]! ... and to make it just worse, they didn't say anything to me, I found out later that night when I tried to make a phone call and noticed the Bluetooth controls were gone !

The part listed on the invoice is 25550-3KA0A which doesn't include these controls. I went online to find what the right PN should be and found that there are two - black with bluetooth, one for the heated steering wheel (25550-3KA2A) and one for the one without it (25550-3KS1A). http://www.courtesyparts.com/auto-p...g-wheel-and-trim-scat/?part_number=255503ka0a
I checked and the steering wheel ring heats even with the part currently installed on my PF so I wonder what is the difference between the two others I found. The only thing I can think is if the switch portion also heats up.

Can someone with a heated steering wheel please check if the portion highlighted in yellow also heats up?
I need this ASAP, the dealer ordered a new part and should be calling me soon to get it replaced. I want to make sure they got the right one.

 

·
Registered
Joined
·
386 Posts
Sorry, don't have it. I went with the "keep it simple, stupid" model.

Sent from my SAMSUNG-SM-G925A using Tapatalk
 

·
Super Moderator
2015 Pathfinder SL - Tech 4WD
Joined
·
2,576 Posts
Discussion Starter #5
Sorry, don't have it. I went with the "keep it simple, stupid" model.

Sent from my SAMSUNG-SM-G925A using Tapatalk
I know the feeling, I owned a 1957 Jeep Willys for 17 years and never had an issue with any of the electronics, navigation, bluetooth, traction control, heated seats, ABS, sensors, etc. :red-neck-laughing:

Many times simple is better.
 

·
Super Moderator
2015 Pathfinder SL - Tech 4WD
Joined
·
2,576 Posts
Discussion Starter #9
I see. It surprised me that someone replied to a thread that I created almost 3 years ago.

Have you checked fuses?
 
1 - 9 of 9 Posts
Top