Nissan Pathfinder Forum banner

21 - 37 of 37 Posts

·
Registered
Joined
·
2 Posts
My wife's 2014 Pathfinder started having the exact same problem with the driver's side control. Removed the top of the center console to switch the 2 controls around and found out the driver and passenger side controls are different switches.
 

·
Registered
Joined
·
1 Posts
I am having the same issue with my 2014 Pathfinder, the drivers side heating/cooling is not working but the passenger side is fine. When I turn the knob for the drivers side the light comes on then goes off immediately. Did anyone identify the fix for this issue? Thanks!!
 

·
Super Moderator
2013 Pathfinder SL, Connecticut, USA
Joined
·
4,393 Posts
I swapped it with M159 relay - the driver side control is still not working - the passenger side was still working.
So I ordered the driver side console control switch.

I will post again after I install it.
ddrancy, others here are interested in your outcome. Thanks!
 

·
Registered
Joined
·
6 Posts
We just picked up our 2015 Pathfinder and I noticed after a couple of days that the heated driver's seat wasn't working (but the passenger was). I took it back to the dealer and they said it looked like the wires to the box controlling the heat had been cut (who knows why). Thankfully it's scheduled to be fixed this Friday.

Am I reading correctly that there should lights indicating when the seats are being heated/cooled? I wonder if one of the cut wires controls that light too. (I'll have to check today to see if anything lights up when the passenger seat is on.)
 

·
Registered
Joined
·
6 Posts
Hi all - new to this forum. Having the same issue as the OP in my wife's 2014 Platinum - driver's side climate controlled seat inoperable, passenger side is fine. Since both sides operate off the same fuses / relay, to me that rules those items out as the issue. Is that correct? It has been stated that if it is not a fuse or relay, it is probably a control unit issue & beyond a DYI fix, but what about a bad selector switch, clogged blower motor filter or broken heater element wire? I will tear into it this weekend, first checking the switch for power and swapping the connectors, and if that isn't it then remove the driver's seat and check the blower motor filter and continuity of the heater elements. In the 24 posts in this thread I didn't see any resolution to this problem. I am open to ideas and suggestions. Thanks!
 

·
Registered
Joined
·
2 Posts
I have the same issue with my wifes truck. the light on Driver seat goes on for about 4 seconds then goes out, passenger seat works no problem.
It is in at the dealer now for repair. turns out they are replacing the Blower for the seat and the control unit, but the kicker is the harness is melted and they will not cover that under warranty and it is $400.
Gonna try to get Nissan to pay for the harness also as this seems to be a common problem.
 

·
Registered
Joined
·
1 Posts
This literally just happened to me on my 2015.. 6 month old Certified Pre Owned... Glad I bought the full warranty as its been a transmission just under a month in, then the rear climate control unit and the drivers side seat heater/cooler went... ended up being a shorted out unit in the seat that warranty covered... but they made me pay for the wiring harness that melted... The shop manager admitted flat out the damage was caused by the malfunctioning unit, and that its a big problem with these 2013 to 2016 models. Nissan supposedly updated the parts in the seat on future models due to the issues, but there is no recall on it, meaning until there is I am forced to pay for the harness and swallow the $400.... Not happy with the quality so far on this SUV... should have paid a bit more and got the Honda or Toyota equivalent. I was advised to go back to the dealer I bought it through and talk to the sales manager, and then the GM. With the frequency of this happening, and the fact it was certified by there shop and had so many issues, they should gladly swallow the $400 to help maintain whatever reputation they have... See what happens when I call next week...
 

·
Registered
Joined
·
291 Posts
I have the same issue with my wifes truck. the light on Driver seat goes on for about 4 seconds then goes out, passenger seat works no problem.
It is in at the dealer now for repair. turns out they are replacing the Blower for the seat and the control unit, but the kicker is the harness is melted and they will not cover that under warranty and it is $400.
Gonna try to get Nissan to pay for the harness also as this seems to be a common problem.
please send a picture of the location for that melted harness, my 15 PF has the same issue it was intermittent for a while but now it doesnt work at all. Lights up and then goes off.
 

·
Registered
Joined
·
291 Posts
I am going to try replacing or cleaning the air filter for the blower motor under the seat to see if that fixes the issue. here is a link to a video.

 

·
Registered
Joined
·
291 Posts
Here is another post from a Maxima forum that will help and describes the problem. If the lights turn off on the knob in 10 seconds or less the issue is electrical, if longer than 10 seconds than the issue is mechanical, ie obstruction in the vents.

 

·
Registered
Joined
·
291 Posts
Just a heads up I have cleaned the filters under the seats which mind had a ludicrous amount of dust build up. The seats work fine now.
 

·
Registered
Joined
·
6 Posts
Thanks so much for the feedback - I am hoping a clogged filter is my issue too - car is 5+ years old and we've never touched it. I watched the video from the Maxima forum and tried to reach under the seat from behind but couldn't feel the filter. Did you have to remove the seat to get to it?
 

·
Registered
Joined
·
1 Posts
I just got back from the dealer to. They quoted me 1400$ to fix the seat plus labour. Saying it was a resister and module. Knowing what I know now they are lying.
 

·
Registered
Joined
·
6 Posts
I just got back from the dealer to. They quoted me 1400$ to fix the seat plus labour. Saying it was a resister and module. Knowing what I know now they are lying.
What did they do to diagnose the issue before they came to that conclusion? The seat climate control module disables the seat heater if anything is out of whack (e.g. out of temperature range), but that does not mean the module is bad. In my case I am betting on a clogged filter or broken heater element wire (what you are calling resistor?), although I doubt the latter since sometimes it works and sometimes not. Doing the work myself, the cost (neglecting labor) is minimal. I just have to get around to it. Good luck with yours!
 

·
Registered
Joined
·
291 Posts
Thanks so much for the feedback - I am hoping a clogged filter is my issue too - car is 5+ years old and we've never touched it. I watched the video from the Maxima forum and tried to reach under the seat from behind but couldn't feel the filter. Did you have to remove the seat to get to it?
You can get to it, there are stretchy straps under the seat that hold the carpet backing on the lower half in place. After pulling the carpet portion up you should have access with the appropriate vacuum accessories.
 

·
Registered
Joined
·
291 Posts
I spent $0 dollars, all I did was take off the entire back of the seat, which later I found out to be unnecessary, find the filter and clean it with a vacuum, I do not recommend wet cleaning it with wipes or anything, like that. That may make it more difficult to clean in the future by embedding the dirt/dust into the filter.
 

·
Registered
Joined
·
1 Posts
I fixed my issue with the driver side heated and cooled seat not working. At the bottom of the seat is the seat climate control module and I found the main plug was melting to the control unit because the power and ground pins in the control module are a smaller thickness than the female side of the plug causing arcing and high resistance which makes the system turn off after a few seconds. I cleaned up the pins and twisted them 45 degrees and plugged it back in to get them a better connection. Now my seat heats and cools just fine.
 

Attachments

21 - 37 of 37 Posts
Top