Nissan Pathfinder Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
the vehicle information display was working just fine and then no display. The gauge displays still light up, but not the information display. Help what to do?
 

·
Registered
Joined
·
88 Posts
Are you talking about the info center in the dash pod between the speedo and tach that you cycle through different settings? or the stereo info display? $8k sounds outrageous.
 

·
Registered
Joined
·
88 Posts
Hmmm, I'm just guessing but maybe a total reboot is in order. That's probably what I would try first. You might try unplugging and plugging back in the BCM to correct a loose/corroded connector issue. By total reboot I mean disconnect the battery and turn on the headlight switch for a few minutes to drain any residual. I'm just shooting in the dark but would hate to take it to a dealer to do just that. I know the displays on our Pathy have gone goofy one time and just a restart fixed it but this description is a little deeper. Sounds like a computer issue.
 

·
Registered
Joined
·
3 Posts
The Nissan dealership told me I needed in the whole entire new computer, apparently they’re really expensive to order with labor they quoted me $8000. This was literally three days ago.
 

·
Registered
Joined
·
155 Posts
Hmm. They are expensive, but not $8k. There are numerous "computers" on the car. I don't think all of them would be that much. Do you have any specifics from the visit?
 

·
Registered
Joined
·
1 Posts
Have the same issue on our 2018 Pathfinder. Pulled out gauge cluster to check connection and all seems well. Don't have a good path forward, was the quote from the dealership was $1,250 for new gauge cluster & $600 for labour/programming. The actual labour to pull out and re-install the cluster is about 15mins so assuming most of that $600 is programming. Either way as expected very expensive for what the part and repair is.

Anyone have any insight on what you would do to move forward to get a more cost effective fix?
 
1 - 10 of 10 Posts
Top